IPKG e pyLoad dopo l'aggiornamento a DSM 5.0 installare

Ieri è stata la, DSM 5.0 Synology ha finalmente rilasciato. Grazie alle numerose funzioni di cloud ho voluto ottenere rapidamente l'aggiornamento. Ma come per ogni aggiornamento, ho due domande importanti per me:

Opere IPKG poi?
Opere pyLoad poi?
Ora posso rispondere a entrambe le domande è "SI". Deve essere installato ma ancora ma che dovrebbe essere un problema. Ecco i passi che devono passare attraverso il loro.

attenzione: La procedura che segue è solo per i NAS con Marvell Kirkwood CPU! Che cosa avete nel vostro dispositivo può essere trovato in questa tabella.

disconoscimento: In sostanza, in gran parte dalla Synology Wiki. Tuttavia, non ha ancora fatto nulla sul DSM 5.0 presi in considerazione e alla installazione pyLoad è ancora un pasticcio. Pertanto, qui in bella maniera strutturata.

installare IPKG

connettersi via SSH al NAS

(Creare se non disponibile con mkdir / volume1 / pubblico)
wget http://ipkg.nslu2-linux.org/feeds/optware/syno-x07/cross/unstable/syno-x07-bootstrap_1.2-7_arm.xsh

I Toccare Inserisci, in linea 21 il 3 Rimuovere marchio "-kw" (senza "")
poi con ESC e :uscita e salvare WQ

PATH e PATH esportazione # decommentare
quindi riavviare il sistema

 

- Così iniziare la sua IPKG
installare pyLoad

Ora il sistema è preparato finora e può essere installato pyLoad, questo migliore manualmente.

Si riceverà un mago con la marca i suoi primi impostazioni possono. importante: Se si pyLoad tu abbia mai installato, dare il diritto di Configpfad (il percorso in cui le impostazioni vengono memorizzate così come tutti i download), perché allora si può fare via con le impostazioni del tuo vecchio impianto.

pyLoad è ora installato e può essere utilizzato anche a http://NAS_IP:8000 - Consiglio di avere un StartupScript. Qui migliore segui questo link.

Installare wget per Mac OS X

Mac OS X viene fornita di serie con l'arricciatura al posto di wget. Mentre entrambi i programmi fanno lo stesso, Tuttavia, mi piacerebbe avere wget, come questo è usato dai miei script esistenti. Prerequisito per la seguente HowTo è un'installazione di mela Xcode Tools sviluppatori, Inoltre, gli strumenti della riga di comando devono essere installati (XCode -> Preferenze -> Downloads -> componenti)*.
Aggiornare: Il link per caricare automaticamente la versione più recente è stato purtroppo rimosso. Così è prima l'ultima versione di wget presso il seguente URL http://ftp.gnu.org/gnu/wget/ e poi inserita nella prima fila in luogo della versione inferiore.

Per Terminal wget poi segue è installato:

E abbiamo anche pulito di nuovo:

In alternativa, l'installazione è anche Homebrew (birra installare wget) Oder MacPorts (sudo port install wget) possibile.

Aggiornare: A partire dalla versione 1.13 installazione wget richiede GnuTLS di default invece di OpenSSL. * GnuTLS ma non è installato di default. ma siamo in grado di indicare l'installazione, OpenSSL da utilizzare in cui si estende la ./configure sopra ad un interruttore adatto: